vendredi 27 juin 2014

Gestion des couleurs en Windev

Testé sous Windev 18

Quelques procédures utiles pour transformer des couleurs.

1. Transformer une couleur en son équivalent en noir ou en blanc :

PROCEDURE CouleurVersNoirOuBlanc(LOCAL gnMaCouleur est un entier)

SI ((RVBRouge(gnMaCouleur) * 299) + (RVBVert(gnMaCouleur) * 587) + (RVBBleu(gnMaCouleur) * 114)) / 1000 < 128 ALORS

RENVOYER Noir
SINON
RENVOYER Blanc
FIN

2. Transformer une couleur en son contraire en noir ou en blanc :

PROCEDURE CouleurVersNoirOuBlancInverse(LOCAL gnMaCouleur est un entier)

SI ((RVBRouge(gnMaCouleur) * 299) + (RVBVert(gnMaCouleur) * 587) + (RVBBleu(gnMaCouleur) * 114)) / 1000 < 128 ALORS
RENVOYER Blanc
SINON
RENVOYER Noir
FIN

3. Transformer une couleur en son équivalent en niveau de gris :

PROCEDURE CouleurVersNiveauGris(LOCAL gnMaCouleur est un entier)
LOCAL
nResultatCalcul est un entier

nResultatCalcul = (RVBBleu(gnMaCouleur) * 0.11) + (RVBRouge(gnMaCouleur) * 0.3) + (RVBVert(gnMaCouleur) * 0.59)

RENVOYER RVB(nResultatCalcul,nResultatCalcul,nResultatCalcul)